Top
310°

German government warns against using Firefox 3.6

The Federal Office for Information Security in Germany has issued a warning to its citizens to switch to an alternative to Firefox 3.6 due to a serious vulnerability discovered in the current version.

Read Full Story >>
blogtechnical.com
Oculus Quest Giveaway! Click Here to Enter
The story is too old to be commented.
IllusionRSN3493d ago

I thought this was about Microsoft at first, with a "serious vulnerability" lmao!

Eric7943493d ago

Germany talking about a serious 'vulnerability' makes me nervous. Poland will be the first to go.

Dark_Vendetta3493d ago

Don't get me wrong, I'm not a nazi but I thought your comment was funny ^^

BYE3493d ago (Edited 3493d ago )

I can't believe people still make these nazi jokes since Germany is a multi-cultural country. Not quite like America, but it's quickly getting there ^^

PirateThom3493d ago

Don't mention the war! I mentioned it once but I think I got away with it!

darkmurder3492d ago

How does this not get removed yet mine about a month back about Blitzkrieg against the Poles did, double standards.

+ Show (2) more repliesLast reply 3492d ago
Fishy Fingers3493d ago

Oh dear, well I'll take my chances, I've read 'this' countless times in the past and never had any problems. Guess it all depends what you go clicking on, whether its shady or not.

devsgreat3493d ago

can i go back to the 3.5 version?

dirthurts3493d ago

Download it from any archive site that has it. Uninstall current version, the install the old version. Simple.

wicko3493d ago

Here is a great site for just that kind of thing:
http://www.oldversion.com/

Mikelarry3493d ago

i just updated mine yester night guess im gonna have to uninstall and go back the the previous version.

Show all comments (21)
The story is too old to be commented.