Top
10°

Starcraft 2: Windows XP - SP3 required

You've been waiting for years to play Starcraft 2 on your Windows XP machine? Than you need Service Pack 3 to install the game. Check the link for more infos.

Read Full Story >>
translate.google.de
The story is too old to be commented.