Top
240°

PSP Firmware 3.50 Hello World

Fanjita and co have done what many thought to be impossible. Today Noobz have released the first-ever, working homebrew on all firmwares! Yep, that includes even firmware 3.50.

"Based on Lumines, the "Illuminati" exploit is a user-mode exploit using a buffer overflow in the savedata file - similar to the GTA exploit."

So if you've got a copy of Lumines (the UMD disc), then you can run homebrew on your PSP, no matter what the firmware version is. Currently, the only homebrew compatible with 3.50 is this Hello World demo, but in the future Noobz intends to release a new HEN and downgrader!

Read Full Story >>
exophase.com
The story is too old to be commented.
Diselage3599d ago

Bravo! Well that didn't take long to find one for 3.50

DrPirate3599d ago

It took less then a month, not bad guys.

cuco333599d ago

when u can use the current custom firmwares to run anything and everything u want to do? and if u want the latest and greatest, give it time before these guys simplify it to the point that it can be done without the lumines exploit, kinda like the way u used to need gta to downgrade, u no longer need it

StateofMind3598d ago

LMAO. I bought one about an hour ago, hopefully they have a bunch in stock.